Windows 10 & Bonjour for wifi access


#1

The move to Bonjour for address resolution works fine on my iMac under OSX but there doesn’t appear to be a Windows 10 port yet so ‘Putty’ won’t connect to my Raspberry.

Is there a resolution or do you recommend I revert to using a static (pre-known) IP address.


#2

Hey,
Did you try installing Bonjour for Windows from here: https://support.apple.com/kb/DL999?viewlocale=en_US&locale=en_US.

-Karan


#3

Yea, tried that but the installer silently exits on Windows 10, I have a workaround which is to query the router for the IP of the lease distributed to the named platform, but this seems to defeat the object.


#4

The installer is expected to exit once the service is installed. Can you try restarting Windows and then just use raspberrypi.local in Putty and see if that works.

-Karan


#5

OK fixed now, logged in OK, didn’t realise a reboot was required.


#6

So just to clarify: rebooting on windows 10 activated Bonjour?


#7

No, something changed after the failed ‘putty’ attempt which may have been during the reboot (Windows Updates). I’ve never been able to recreate that precise set of circumstances and achieve connection after a reboot alone. But interestingly I am doing some testing with NodeJS and have a custom process listening on a Pi port, a Chrome browser on Windows succeeds in connecting and triggering a response and I’m guessing that leads to caching of the name / IP address pair, possibly in the local registry, because subsequent ‘putty’ invocations (with and without the ‘.local’ suffix) succeed.