Avrdude does nothing when trying to program BrickPi firmware


#1

I’m using an AVRISPMK2, and the BrickPiFW_UC1 batch file on Windows 10.
All avrdude does is reply “avrdude done. Thank you.” each time it is invoked, and nothing else.
Needless to say, the firmware doesn’t get changed.
Thanks for the help,
Rolly.


#2

@rolly,
Are you using this tutorial to upload the firmware. Can you post a screenshot of what the window looks like. Can you also run this command in the command prompt and post what it reports back:

avrdude -P usb -c avrispmkII -p m328p -U lfuse:w:0xFF:m

Can you also post a few pictures of the connections between the AVRISP and the BrickPi.


#3

That’s the tutorial I’m using.
Here’s the output I get from running the batch file:


Here’s a photo of my setup:

Here’s what I get from running the avrdude command you suggested:


#4

I notice that on the programmer’s ribbon cable, the right-most lead wire crosses over to become the third wire into BrickPi connector (as you can see in my photo).
Is this what’s doing me in? I do get a green light from the programmer.
If so, how should I rearrange the wires?
Thanks for responding.


#5

Here’s another photo of the cable, along with a patch cable included in the kit.
If I new what goes to where, I would happily uncross the wires.


#6

Any suggestions as to what I can do to reprogram my BrickPi firmware would be much appreciated.
I’ve uploaded the email I got back from the programmer vendorMSGD004 Atmel AVRISP AVR ISP mkII doesn’t work.txt (2.1 KB)
[Where are you karen? - I replied right quick with more info than you asked me for]


#7

@rolly,
Sorry for taking this long to reply back.

I am not sure why, but the avrdude program is not showing the entire output and the output you are getting is very weird. Usually it gives a verbose output of what is going on and if it passed or failed.

Can you run the commands with an added -v in the end, so that it run in verbose mode and see if you get any more information out of it. Which operating system are you using, and would it be possible to run the program on another machine and see if you get the same output or something else.


#8

Thanks for getting back to me, and for the great suggestion. avrdude can’t open device USB.
Screenshot is attached. AVRISP mkII does show in my Windows 10 device manager. I’ve tried on another PC with the same result

- also Windows 10.


#9

Thanks to karan’s suggestion, I got it working. Avrdude would’nt work on 2 Window’s 10 PCs, not on a Mac OS system, but it worked like a dream on a Ubuntu PC. My flaky looking, wired crossed cable was OK. Now to get the firmware change I was trying to make to work.
Any suggestions for doing a debug like printout from within BrickPi?


#10

@rolly,
Great to hear that it is working for you now.

By this,

do you mean how to get debug output from avrdude from the Pi or something else. Also, did the firmware upload work properly for you?


#11

I was able to get my changed firmware into the BrickPi (I changed the version # to 3).
I was asking how to get the BrickPi firmware to send debug messages to the outside (like print statements, or whatever). I guess, when its hooked up to the programmer & avrdude wuld be OK too.


#12