Beta Testers Wanted! Raspbian for Robots


#1

UPDATE for 2016: We have just released a slight upgrade with some improved networking, and the latest version works with the Pi 3 right out of the box.

We have a new, awesome version of Raspbian for Robots available for beta testing! Get a first look at our updated software, with new, more intuitive navigation and Scratch integration.

Important Note!

    The Hostname is now "dex" The Username is still "pi" The default password is now "robots1234"

You can download the image here on Sourceforge.

For a quick refresher on how to burn the image to an SD Card, see our guide on how to Install Raspbian for Robots Image on an SD Card here.

Here’s a partial list of updates and upgrades here.


#2

Apparently I’m a beta tester because I pulled the SD image dated 11-1-15 from Sourceforge and installed it on a new GoPiGo today. Before I got to the forums here, I had decided the best way to “untether” the robot from the HDMI cable was to connect via SSH (I have 3 other RPi units in the house that I do the same with). So, I quickly discovered the default password was not ‘raspberry’ as I expected. Now I know about the VNC option, so may try that later. I’m guessing the VNC password is the same as above. Having quite a bit of fun so far, thanks for a cool product.


#3

Hey Darrell, thanks and welcome aboard! Thanks for contributing to the project, and thanks for letting us know about it. Please let us know if you have any questions or problems with the software, we’d really like to know about it!

Indeed the VNC password is robots1234 as well.

John


#4

Really cool!
I might delete my current brickpi operating system and get this one on the ready to use sd card I bought
Just one question.
Will that work with the brickpi better than the current version?
Best regards,
H1pp0s


#5

System report,
System is slow to start up after a blank screen for about 2 or 3 mins.
System has crashed once in the last 5 to 10 mins and I had to reboot to restore use.
From what I have used it for, its been really thought through.
I really like it, it’s easy to navigate and very inviting, much better than the older version just a bit slower that’s all.

Best regards,
H1pp0s

Made using the system.


#6

Hey H1pp0s,
The newer image should work better with the BrickPi. It gives new easier options to run Scratch and troubleshoot the problems too.

Do you have any details about the crash and the slow start. Can you post your kern.log and syslog files from /var/log. They might have some information about the boot problems and the crash.

Thanks again for trying out the image.

-Karan


#7

I only just started using it then and now its starting to get a bit faster and that crash was the only one since i got the system so i think it was just the new software settling in if you get what I mean.
Kind regards,
H1pp0s


#8

I bought a GoPiGo and I’ve tried to download Dexter’s image file 4 or 5 times now (the .rar and the .zip files) but none of them have worked. They’re all “corrupted.” What should I try now?

Hope this helps.

Peter


#9

Hey Peter. I took your e-mail off since you might not want people spamming it!

Have you tried the google download link on this page? Usually sourceforge is super fast. However, maybe there’s a problem in your area?


#10

It’s Peter again. I downloaded the image on another computer and burned it to an SD card. It wasn’t possible to use the video instructions for ssh’ing in as mentioned above. Once I changed to dex.local, and so on, the ssh’ing was successful. But to run the demo I had to vnc into the Pi and click the icon and gui in the desktop. That worked too. I’ll start writing programs, but I’m pretty confident from here on out.

I suppose nothing computer-related can be perfectly smooth but you have to update your tutorial videos. They’re very helpful.

Thanks!

Peter
California


#11
It wasn’t possible to use the video instructions for ssh’ing in as mentioned above.

Hey Peter which video were you pointed to? Videos for connecting are now up here: https://www.youtube.com/playlist?list=PLGXEJ4Ye1qCNZ9OGYTXh7o8jSgO5-NHjY


Raspbian for Robots (Jessie) and Pixel - WiFi times out
#12

Now the holidays are almost over, I’m going to have some more time to experiment with the GoPiGo and the new version of Raspbian for Robots (RfR). I’m curious about the status of RfR with Raspbian Jessie and the brand spanking new Pi Zero! I’m willing to do some testing with Pi Zero and the GoPiGo (I’ve also got my spiffy new GoPiGo2 from the Kickstarter project). Of course, the first stumbling block will be the fact that the Pi Zero only boots up with Raspbian Jessie (older Wheezy versions just blink the ACT light slowly and makes it look quite lonely).


#13

Hi everyone! Took me awhile, but I’m back to working with the GoPiGo. I switched to a Raspberry Pi Model B (older model) and it seems to fit on the controller board a bit better. Still wish the header socket was a bit taller so the Ethernet port has a better clearance when the pins are fully inserted. But that’s beside the point.

I pulled down the 2016 version of the Rasbian for Robots and flashed a new SD card. Got everything installed, updated, checked the firmware version, etc. Connecting with WiFi, SSH and VNC through the web browser on my Mac (OS 10.10) just fine, no issues. Installed the ultrasonic sensor and giving that a test drive.

Looking good!


#14

I’m using the 2016 updated version of Raspbian for Robots. I’m having a weird sporatic issue with the WiFi. It will work at the beginning (Edimax Nano), I did the updates for Raspbian and Dexter software, rebooted and then no WiFi (I get the “Unable to Associate” error). Switched out to a different brand of USB WiFi (LB Link), it works until a reboot and second one dies. Anyone else having this issue?

Second topic: Does the “Browser streaming robot” project work with this version of Raspbian for Robots? When I do get the WiFi working for a few minutes, when I browse to http://dex.local I get the start screen for connecting with VNC, etc. Does the other project need the port number changed for the web server? Something like http://dex.local:8888 perhaps? I’ll look deeper into the code, but looking to see if it’s been tested on this new version. Thanks!


#15

Hey Darrell, haven’t seen this, but I am using the DI wifi dongle. How are you powering the Pi? We usually see wifi issues when the power drops on battery power. Could that be the issue?

I think we’re picking up the browswer streaming robot in a different thread!


#16

Hi John - the power might have been some of the issue, because I started out running from the batteries. I also ran the RPi from a 5V 1.5A power supply with the same results. Strangely enough everything worked fine when I was using Raspbian for Robots SD image dated 11-1-15 in December. I was using a Raspberry Pi Model B (ver 2) with the Edimax Nano WiFi adapter and then again this month. The only thing that changed is I flashed the Raspbian for Robots 01-05-2016 version to the SD card.

Tonight (2/25/16) I had no luck with the WiFi, even after starting from the beginning (flashed the SD card, connected via Ethernet to get VNC access, enabled WiFi) and again could only maintain WiFi for about 5 minutes and then everything dies. So, thinking maybe it’s the older Model B board, I pulled a brand new Raspberry Pi Model B+ out of my inventory and again started from a fresh image to the micro-SD card. Same result using the Edimax Nano WiFi.

I don’t have any of the Dexter Industries WiFi dongles. Which chipset does it use? The only other brand of USB WiFi I have on hand is the Raspberry Pi Foundation’s WiFi adapter (I keep a few of them on hand, but I can’t get those at wholesale!). I know that adapter uses the Broadcom chipset (Windows 10 IoT requires this adapter). So, now the configuration is a GoPiGo 1, Raspberry Pi Model B+ and Raspberry Pi WiFi adapter. I got connected via VNC and did the Raspbian update, Dexter Industries software update, Hardware update and then rebooted.

[drum roll please]

The WiFi reconnected and seems to be holding.

Things of note:

  • Connecting to the RPi with the Ethernet cable does not work with Ubuntu Linux. I had to switch to a Mac OS X laptop
  • The newest 2016 Rasbian for Robots does not appear to be compatible with the Edimax and LB-Link USB WiFi (I wonder if they are the same chipset?)
  • I wasn’t able to rule out the issue was with the Model B board and the 2016 software version

#17

Hey Darrell,

Wow, thanks for the detailed response. These sorts of responses help us think of new ideas, and help us work through these issues. So thank you SO MUCH.

First, the chipset on the wifi dongle is Realtek Semiconductor Corp. RTL8188CUS 802.11n. This should be supported on a standard Raspbian image (as well as our image).

Question about the Ubunut Linux: are your running and mdns service? I think that might require avahi, are you running that on your ubunut system?

The newest 2016 Rasbian for Robots does not appear to be compatible with the Edimax and LB-Link USB WiFi (I wonder if they are the same chipset?)
Have you updated Raspbian? Does it work with the Jesse version?

I will go ahead and try this with a Model B board, I don’t think we have yet!

Best, John


#18

Thanks for that info, John. That chipset you listed is the same used in the Edimax Nano, so they’re essentially the same. I did several different “trial and error” experiments and ended up moving the Edimax to a different USB port. Also, it does make a different how the wpa_supplicant.conf file is configured, especially the value for pairwise=CCMP (pairwise=TKIP will fail). Also, there appears to be two different GUI apps for managing the WiFi. The default one with the latest version of Raspbian, the icon looks like two monitors, the old GUI icon looks like concentric semi-circles. I noticed if you click on the DI icon for “Wifi Setup” you get the older GUI. That seems a little confusing.

Long story, shorter … the Edimax Nano seems to be working now. So, I guess it just got off on the wrong foot. :slight_smile:

Addendum: Upon reboot, it takes awhile for the WiFi to work itself out, but it eventually connects again. After 5 minutes or so, it all dies. So, I am back to the original problem.


#19

Hmm. Does manually editing wpa_supplicant work at all to solve the problem? Are you able to just delete everything and enter in the wifi info there?


#20

I dug a little deeper (after getting some sleep, I was up really late trying to work this out), and although the DI WiFi is also a Realtek, it might be a slightly different model. The Edimax nano is RTL8182cu versus the RTL8188cu. I found some blog posts describing a power-saving bug (or is that a “feature”) that needs to be disabled in a file: /etc/modprobe.d/8192cu.conf

I noticed the Raspbian for Robots image does have that file, but not exactly as the fix describes. Here is what the file contains now:

Disable power saving

options 8192cu rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1

The recommended fix is:

Disable power saving

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=1

There’s no mention of what value rtw_ips_mode needs to have, so I left it. I’ll try this change and post an update.

For the benefit of anyone else, here’s the configuration in /etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid=“Grandin Co-Lab"
psk=”**************"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

network={
ssid=“HOMENET12"
psk=”*************"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

I’m sure you can tell which one is “office” and which is “home”

PS - the Edimax nano works without any problem on my home network. It’s at the office, where I work on these projects (and record my hobby videos), that has the WiFi dropping out. I feel it still might be the power saving “feature” of the Edimax. Apparently the Rasberry Pi Foundation WiFi dongle with the Broadcom chipset does not suffer the same fate.