Brickpi 3 won't boot after editing crontab


We created a program that we want to run after our Brickpi3 boots up. I saw that you can do this thru the “crontab”; so I performed the following steps. Now it seems that our Brickpi3 will not fully boot up, because I tried to ping “dex.local” (no response), and access the VNC via “http://dex.local/” in a web browser but the url is not found.


  1. sudo crontab -e
  2. entered the text “@reboot sudo python /home/pi/{DirectoryPath}/{ProgramName}.py /home/pi/{DirectoryPath}/{LogFileName}.txt”
  3. Keyed “ctrl o” to save
  4. Keyed “ctrl x” to exit
  5. sudo reboot


Thanks in advance for any and all help!

Hi @c-spurgeon,

I think you may not be running the right OS on your Raspberry Pi. Let’s check this before we do other things.

Could you check the following post and tell us if that solves your issue?

Short note: Make sure to press the right arrow to see the whole message from the quoted post.

Thank you!

I bought this preinstalled “Raspbian for Robots” sd card and then ran the DI update (ref my last issue).

In the above line, have you replaced {DirectoryPath} and {ProgramName} with your actual values?
What’s the line that you entered?

I can’t remember the exact path, and I can no longer access the BrickPi VNC desktop (via my windows 10 PC) too see what I entered.

I see there are 2 options (ref 4. Connect to your Pi Robot and get it going) for connecting to the BrickPi. Instead of accessing thru the VNC, should I be able to connect to the BrickPi if I hook a monitor directly to it?

It is definitely worth a try to boot up with monitor and keyboard. But depending on the cause of the issue, it may not work. At that point, if monitor/keyboard fails, you would have no choice than to re-image the SD card.

Good luck!