BrickPi compatible with Raspbian Bullseye?

I have a Raspberry Pi 2 with the original BrickPi hardware. Will the BrickPi software ever be made compatible with the latest Raspbian Bullseye, or are there any tips on getting it to work? I’d like to use current releases of the software tools.

Thank you for any info!

2 Likes

First off, do you see any irony between “original BrickPi” and “current releases”? I’m just tweaking ya!

Since you’ve been gone:

  • the company has changed: Dexter Industries acquired by Modular Robotics
  • Support has changed from this forum to support@modrobotics.com
    Therefore the forum is where users help one another now.
    MR may appear but support is via email.
  • the product lines have changed
  • the OS support for supported ModRobotics products has changed

(I am a GoPiGo3 robot user, in no way affiliated with DI/MR. These are my observations)

To your question “any tips on getting it to work”:

  1. Install Legacy PiOS (Current image at this time is April 2022)
  • Use Raspberry Pi Imager v1.6.2 or later
    • Choose OS → Raspberry Pi OS (other) → Raspberry Pi OS (Legacy)
  • Set it up to connect to your network
  • Make sure it is fully working
    • setup with remote shell or VNC to the desktop
  1. Follow the instruction for installing the “original” BrickPi+ software (not BrickPi3)

Again - I do not own a BrickPi+ or BrickPi3 so I am just responding to your “any tips?”

1 Like

Thank you very much! I knew I wouldn’t reach any sort of official support here, but I’m glad users like yourself are still looking out for other users!

And, thank you for letting me know about the Raspbian “Legacy” version! That sounds like it’ll probably work fine, and it also satisfies my nervousness about using the BrickPi OS image that’s several years out of date. :grinning_face_with_smiling_eyes: I’ll give it a try and I’ll report back about what happens!

2 Likes

I found out that the BrickPI tools are based on Debian 7 “Wheezy”, whereas Raspbian Legacy is Debian 10 “Buster” (and the latest Raspbian is Debian 11 “Bullseye”). So even getting it to work on Legacy might be a challenge … we’ll see!

2 Likes

I’m pretty sure it will work. Legacy solved the last brickpi user’s issue

1 Like