BrickPi No SPI Response "catching classes" issue

When i try to run my code (It’s just a simple program that runs a motor) it gives me the following error :

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/brickpi3-0.0.0-py3.7.egg/", line 295, in __init__
  File "/usr/local/lib/python3.7/dist-packages/brickpi3-0.0.0-py3.7.egg/", line 411, in get_manufacturer
OSError: No SPI response

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/pi/Desktop/[USER]/src/", line 15, in <module>
    BP = brickpi3.BrickPi3()
  File "/usr/local/lib/python3.7/dist-packages/brickpi3-0.0.0-py3.7.egg/", line 298, in __init__
TypeError: catching classes that do not inherit from BaseException is not allowed

Anyone have a solution ? I tried to re-install BrickPi3 and it re-installs fine but it doesn’t solve my problem. I also tried to update the firmware with the command sudo bash /home/pi/Dexter/BrickPi3/Firmware/ but it produces the following message:

Found +RPI4
Flashing the firmware using a Pi4 is not currently supported

I don’t know what I did wrong.


Oh, Pi4…. Legacy Pi OS?

Pi4 Folks that have seen “No SPI Response” before have had success by using Legacy Pi OS:

1 Like