Can't interface with a GoPiGo2

gopigo
r4r

#1

I bought Gopigo2 and update the software and everything. BUT it doesn’t work. Current I update to Gopigo3 and still not work. Could anyone advise me how to me it work.

Photo - https://drive.google.com/open?id=1PiR-PO4cZhi2ycOoRECbV14gKSgVUH56

Thank you so much


[SOLVED] No SPI response. GoPiGo3 with address 8 not connected
#2

Hi @chutawatl,

You’re trying to run a troubleshooter for a GoPiGo3 when you have a GoPiGo2. Let’s make it clear: there are 2 robots:

  1. The GoPiGo2 - which is our older model.

  2. The GoPiGo3 - which is the new one.

The only one you’ll see on our website will be the latest GoPiGo robot, which is the 3rd revision of it and not the old one.
https://www.dexterindustries.com/gopigo3/

Now, in order to use the older version, you need to run the following command in your terminal:

curl -kL dexterindustries.com/update_gopigo | sudo bash

This will take some time, but once it’s done, you’ll be able to interface with your robot.

By the way, here’s the repository meant for the GoPiGo2 robot:

Hope this makes things more clear for you.

Thank you!


#3

Hi

Thank you for the quick response. I bought a GoPiGo2 robot, BUT the firmware was updated to GoPiGo3, When I check I was confused.

I will try your command line; once I have resulted, I will let you know.

Thank you


#4

Hi

I did try the command. It installed for a while then give me to reboot and it still not detect GoPiGo.

Please advise


#5

Hi @chutawatl,

Let’s do the following thing: install script_tools and then check within a Python shell what’s the detected robot. Here’s how you can do it:

Step 1

curl -kL dexterindustries.com/update_tools | sudo bash # for installing script_tools

Step 2

Enter a Python shell and run the following code:

from auto_detect_robot import autodetect
print(autodetect())

Step 3

Try the GoPiGo Control Panel again - even though script_tools shouldn’t be the one causing this, it’s worth trying it again.

After you do all these, please let us know what that function call returned and if the control panel recognized the robot.

By the way, did you run the curl command I had given you a while back? Even though you already told us this, there is a time gap between your 2 replies, so we want to see if you had run it a month ago or now.

Thank you!