Connecting to dex.local


#1

windows 10, RPi3, BrickPI3, Raspbian for Robots

I thought I’d reply because my problem is a little different from the ones I’ve seen on the forums. Here goes…

After the initial set up I try to ping dex.local and I get…

Pinging dex.local [198.105.254.17] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 198.105.254.17:
_ Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),…_

I have no idea where the IP address is coming from when I ping Dex.local. Simple enough problem. Here comes the curve ball. I followed a tutorial that I found on another forum entry that was for Mac. Long story short it worked. It involved statically assigning an IP address to the Pi and then pinging it. That worked with a caveat. Ping to the static IP address was successful & I could access the interface from my browser; however, I still got the same output from command line when pinging dex.local. Very odd. I’ll cross post this and see what answers may pop up. Nothing wrong with archived knowledge =)


New GoPiGo2 - ping not working dex.local
#2

For dex.local to be recognised by a Windows machine, you need to have Bonjour installed. Can you confirm if this is the case or not?

Or if you don’t want Bonjour, then you can use dex/ instead in the url bar of your browser of choice. That might work too.

Cleo


#3

Such a nice response time. No, I do not have Bonjour installed. Here is where I am so far: I was reaching the BrickPi3 through an Ethernet cable on my Windows machine. I connected to my home wifi, disconnected the Ethernet cable, and could not ping to the Brick anymore via Ethernet cable either. Its connected to my TV at the moment and its connected to the wifi.

Edit 1: Command line says “Destination Host Unreachable”.
Edit 2: On Raspbian, the network icon says, “link is up, configuring” by eth0. And it never changes.


#4

Let me make sure I understand.
You currently have your BrickPi3 connected to a TV, with keyboard and mouse. So you’re “physically in” as opposed to “network’ed in”, if that makes sense.

On the newest Raspbian, the Wifi is treated slightly differently. It must have a country setting. Did you do that?
country

Also, can you connect your BrickPi3 to your local wifi? If so, make note of the IP that’s been assigned to it. Can you reach that IP from your Windows computer?


#5

I was networked into my BrickPi with an Ethernet cable after I followed a video I found in one of these forums. It was for Mac but I did the same thing on my Windows Machine. After successfully pinging the new statically assigned IP address I signed into it via my web browser. I connected to my home wifi successfully & then disconnected the Ethernet cable; however, I could not ping to the device nor sign in via web browser. I plugged the Ethernet cord back in and tried to ping with no success.

So, basically, after I connected to my wifi and disconnected the Ethernet cord I wasn’t able to reach the device at all.

I currently have version 9 of Raspbian for Robots that was made in June 2018. The video I found & followed on forums to allow me to network in via Ethernet is (https://www.youtube.com/watch?v=q7mdXGxBuDI&feature=youtu.be)


#6

update [SOLUTION]: Reflashed SDcard, downloaded Bonjour (could then network in with dex.local), signed into home WiFi, disconnected Ethernet cable, could not sign on with dex.local, hover over network task icon and network in through IP address that it gives next to wlan.


#7

So connecting via the IP address works. Good.
Is it possible that your home network has 2.4GHz and 5GHz running? The robot will be on 2.4GHz. If your computer is on 5GHz they most likely will not be able to talk to each other by name.

Cleo