GoPiGo3 Power On Issues

gopigo3
powersupply

#1

I just recently purchased 9 GoPiGo3s for my classroom and i am just trying to get 1 of them functional then copying the setup to the others. The goal is to teach python scripting to my students on these devices.

**I am currently testing out Raspbian for Robots. I also have a screen (HDMI), mouse, & keyboard plugged directly into the robot. The below issue persists even with all of these items not plugged in.
**Using Rapsberry Pi 3 B+.
**I downloaded the most recent version of Raspbian for Robots from the Dexter Industries site.

Right now it has issues powering up with batteries plugged in.
1.) If plugged into the wall out, it will stay on no issues.
2.) If plugged into the wall, you plug in the batteries and unplug the wall outlet, it will stay on no issues.
3.) If only the batteries plugged in, it will only twitch, red power light blinks once, then it turns off.

I have updated via the command line w/ the sudo curl -kl www.dexterindustries.com/update_gopigo3 | bash and the above issue still persists. The above command puts a control panel icon on the desktop that tells me to update the firmware in order for it to work.

I figured that the above command accomplished that. So i clicked on the DI Update Icon, selected GoPiGo3, updated the firmware & Dexter libraries etc. The control panel icon disappears and the same issue persists.

When i click on the troubleshoot & test, it gives me the error “No SPI response. GoPiGo3 with address 8 not connected”. I reflashed the SD card thinking maybe it got corrupted or something, no changes. I even installed Raspbian prior to plugging in “Raspbian For Robots” to see if that would make any difference, no changes.

I also have tried an SD card with just regular Raspbian on my own personal GoPiGo3 (test dummy prior to making changes to classroom) and i have had zero issues.

I am at a loss for ideas on how to fix this.


#2

Hi @JDahlke1865,

So can you confirm us that you’re actually trying this with just one of your GoPiGos?

Next, could you try running this command that flashes the firmware directly and then let us know if running the troubleshooter/test does it for you?

bash ~/Dexter/GoPiGo3/Firmware/gopigo3_flash_firmware.sh

This command shouldn’t take too much time.

Next, about the Pi/GoPiGo not booting up when only the batteries are plugged in, could you check if what voltage your batteries have? That’s really important and can make the difference from a faulty board to just low batteries.

If it happens to be faulty board, then we’ll have to replace it and have the faulty one sent back to us for further investigation.

Also, you might be interested in using DexterOS instead of R4R if you’re going to be teaching the students how to use Python and such with your GoPiGo3. I find Raspbian For Robots to be more hobbyist-oriented and not such a good tool compared to DexterOS in classrooms. Then again, it depends on what your context is.

Here’s more on the differences between DexterOS and Raspbian For Robots (R4R):

Thank you!


#3

Yes sir, i am only trying this on the one GoPiGo, let’s call it George.

i entered that command and the same issue still persists.

In regards to the batteries, i have tried 2 different sets of 8 Energizer batteries from 2 different packages in addition to 1 set of 8 of the rechargeable kind. All 3 sets of 8 batteries yielded the same result of not turning on the gopigo without the wall outlet. I tried multiple sets in hoping that it would be the batteries i was using would be the problem.

I will be building another gopigo today in hopes that it will not have the same problem occur.

In regards to Dexter OS Vs R4R Vs Raspbian, i have been comparing all of them to see which would best fit our curriculum to make it easiest for the students. I like Dexter OS, but i haven’t been able to figure out how to execute a python script that has been written in a .py file. I have to copy it into one of the workbook cells and then execute it or open a terminal and execute it from there. Maybe i am missing something?

I have been testing all of these on my first GoPiGo, not George, and they have all been working wonderfully. DexterOS & R4R require significantly less updates to the software/firmware in order to execute scripts. I have created a service on regular Raspbian that executes the intelligent object avoidance script upon startup. That required a lot of research to get the libraries to function properly.

I appreciate all of the effort you have gone through to create this teaching medium and the guidance in helping me fix this one!

-JDahlke1865


#4

@RobertLucian

I have been trying everything that comes to mind and i still can not resolve the issue mentioned above.

Do you have any new ideas?


#5

Hi @JDahlke1865,

I’ve got a few questions for you before we go forward:

  1. Does the power LED turn on when you power up the GoPiGo3 or is it just the Raspberry Pi that lights up?

  2. What is the output of the command I have given you before? The one to flash the firmware onto the board.

  3. Could you try it out with another, brand new GoPiGo3? Statistically speaking, the chance of seeing another GoPiGo3 not working are really low.

Thank you!