Pi-4 on the GoPiGo-3 shows low voltage warnings under light loads

Continuing the discussion from Let's Bang GoPiGo3 OS v3.0.1:

This is a fork of GoPiGo OS thread noted above.

Please read the relevant messages to understand this continuation.


While working with GoPiGo OS on Charlie, I noticed a LOT of low power warnings and associated throttling even at relatively light loads.

I am currently investigating why.

I have:

  • Updated the Pi-4 firmware to the latest version.

  • Tried this with both GPGOS and R4R.

  • Ran an update on the GoPiGo OS.
    (Which breaks GoPiGo compatibility.)

  • Tried this with my usual external supply, my batteries, and my big bench supply.

Since I broke my clip-leads, I am going to rebuild them with thicker wire so that wire resistance will be less of a factor.

Ultimately, I am going to replace the Raspberry Pi-4 board itself as I suspect that there may be a problem with the voltage controller chip on the Pi itself.

More later.



Merging @cyclicalobsessive’s thread:


Bringing this along -


It turns out that the ultimate cause of this problem may be the SSD that I have plugged in - especially since I have it plugged into a USB-3 port now.

USB-3 supports power negotiation and the device, (the SSD), can request the USB controller to allow additional current/voltage to be delivered to the USB device.