Raspian for Robots VNC/Terminal "took to long to respond" at 169.254.*.* IP Address

r4r
faq

#1

I am trying to set up my BrickPi3 through my PC (windows 7), chrome (or IE) and ethernet. I am able to connect to the Welcome to the Rasbian for Robots screen using http://dex.local When I click on either links (VNC or terminal ) both generate the error:

This site can’t be reached
169.254.59.3 took too long to respond.
Search Google for 169 254 8001
ERR_CONNECTION_TIMED_OUT

Things I can do:
I can connect through a monitor and can see the regular raspberry pi screen
I can ping dex.local from the command prompt.
I can also gain access through putty over the ethernet connection.

Any help or suggestions would be appreciated.
Thanks


#2

Hi @pagmac17,

The reason your Pi has the 169.254.59.3 address is because it couldn’t get an IP address from its DHCP server. One of the reason it couldn’t contact the DHCP server could be caused by either:

  • Not installing Bonjour.

  • Or by not sharing the internet connection from your WiFi to your Ethernet interface.

So, my question is: do you have Bonjour installed on your computer?

Thank you!

Here’s a link on 169.254.*.* IP addresses:
http://packetlife.net/blog/2008/sep/24/169-254-0-0-addresses-explained/


#3

Thanks for your response. I think my firewall was preventing me from using the ethernet interface but I was able to solve the problem by going through wifi. Once I connect to the RPI using putty I enter the command:
vncserver
through the putty connection on the raspberry pi. Once I do that the connection works every time. Thanks for your help (I wasn’t able to enable the vncserver through the raspberry pi config and have it “stick,” so I just run this command and then start VNCserver on my PC.)


#4