Remote connection to Raspbian for Robots?


Please note a similar posting at:


In my case SSH via putty returned “connection refused”

How do I set up VNC? Is there anything particular I need to do or do I just grab a Win-7+ installer and go?

Note that so far, everything I’ve done has been with keyboard, mouse and monitor attached.

How I set mine up:

sudo apt-get install tightvncserver

pw: your_new_vnc_password
viewonly pw: no

default is 1024x768 can change: tightvncserver -geometry 1920x1080

to get it to start automatically at boot:
sudo nano /etc/rc.local
add before the exit 0 line:

su -c “tightvncserver :1 -geometry 1920x1080 -depth 24” pi
exit 0

I often use the Mac Remote Desktop and connect to vnc://carl.local:5901
Don’t know if Windows Remote Desktop will do vnc, if not install vnc “client” (not server) on your machine.

Can also use the built-in browser noVNC connection instead of going through this if desired.

1 Like

Interesting and thank you!

Interesting because - according to what I read here on Dexter’s site - both SSH and VNC should be working “out of the box” - at least on Raspbian for Robots. Should I assume that this information is stale/no longer accurate?

Assuming that these features still exist:

  • What do I do to enable them?
  • What do I do to access them?

Assusming they don’t exist:

  • Should I just take cyclicalobsessive’s advice and install both VNC and SSH on my 'bot?


Did you at anytime:

=== Enable SSH

  • create file called “ssh” (or ssh.txt) in the Boot partition
1 Like

Don’t forget the new way to ask DI:

Interesting - I just noticed that changed from what I had written down - used to be:

ask or email

1 Like

Which version are you referring to - the R4R Stretch or the experimental R4R Buster?
(There is enough about Carl that is experimental. He’s not tried experimenting with his “heart” yet.)

1 Like

Stretch. - not sure if it’s the latest-and-greatest or not. Right now my 'bot’s been set aside for the time being.

Buster’s got more bugs than a bait-shop. That includes derivatives like Raspbian Buster, Mint Buster, (and I am assuming the other Ubuntu spin-offs as well)

Unless there’s a pretty darn good reason, I’m sticking with Stretch on Dexter until there are a few more iterations of Buster to work with.

I put Mint 19.3, (Buster), on my laptop along with Win-7 and . . . I’m thinking about re-installing 18.3 (Stretch) since Buster broke compatibility with a lot of stuff and everyone is waiting for the upstream fixes from Debian.

No, didn’t do that.
I know it’s a, (semi-unpublished), “hack” to get SSH working on Dexter O/S, but (silly me!) I had assumed that “working out of the box” meant “not requiring any sidewise hacks to make it work.”

So, you’re telling me that this is necessary for Raspbian for Robots too? I’m pretty sure I enabled SSH, (along with VNC, camera, etc.), in raspi-config within Raspbian for Robots. Shouldn’t that be sufficient?

Of course, I was working on three-or-so different Raspbian installs at the time, one for my granddaughter, (that ultimately didn’t do what I wanted), along with some stuff on a Pi-4 and trying out how to get a 7" touchscreen display to fit Charlie, (it’s too big), so I might be confused and I will go re-check. Despite the “R” in my handle, “Confused” is my middle name! :crazy_face:

I’ll go try that.

What are the default ports for the various remote access protocols on RFR?

One of these days when we have more time, (yea, right!), we’re going to have to start a GitHub repo - or maybe glom onto Dexter’s repo making a documentation fork/project - and start a documentation release. We could grab all of these little tid-bits, odds-and-ends from various nooks-and-crannies on the web site, etc. etc. etc. and make a consolidated document describing how to use Dexter, Cinch, and RFR in meaningful and useful ways.

Of course, we’d have to put up with a lot of lobbying against it from both bricklayers, pillow makers, and analgesic drug manufactures - since there would be a significant decrease in head-banging!

Sorry, I thought you were talking about Raspbian For Robots. I don’t believe there is SSH access to DexterOS.

1 Like

Just did that with both my recent questions.

Quote from the Borg: Resistance is futile - you will be assimilated!

I just hope and pray that Dexter doesn’t completely dissolve. The fact that Dexter’s CEO “retired”, (translation: invited to leave), is not a good sign. I’ve been on “the short end” of a “merger of equals” too many times for any kind of hope for Dexter’s ultimate fate.

1 Like

No, there is SSH for DexterOS. It’s the “ssh.txt” (or maybe just “ssh”) touched inside the root directory. That’s an “on the down-low” trick for DexterOS that someone, (cleoqc?), mentioned way back when I was just cutting my teeth on this beastie. Now, instead of just cutting my teeth, it’s developed into a full-blown BD/SM experience! :crazy_face: :flushed:

I’d never heard of this for Raspbian for Robots - everything I read made me believe that Raspbian for Robots was, (supposed to be), working as installed and/or after raspi-config.

As Cleoqc has said before, Raspbian for Robots is a “Dexter Industries” bolt-on for stock Raspbian. In fact, you can install it into a Raspbian image yourself.

In defense of sensibility, the farther a user gets from downloading either the DexterOS sd image, or the Raspbian For Robots version of Stretch sd image, the less likely it is possible for DI folk to be able to “support” a user.

When we start talking about what is possible, it is quite possible to leave the safety of the herd.

1 Like

Sorry if I mis-spoke.

What I was trying to mention is that - unlike DexterOS - Raspbian for Robots is (essentially) stock Raspbian with a few bolt-ons, as far as I understand. Therefore, there should not need to be a /boot hack for SSH. Of course, “should not” is the operative phrase here. :wink:

I booted up Charlie with a monitor, keyboard and mouse and checked raspi-config. Camera, SSH, VNC, i2c, serial, spi, and the Kitchen Sink are all enabled. I’m getting ready to give Charlie a static IP for both eth0 and wlan0

Back again with more news:

  1. The “touch ssh” hack in the root directory is not necessary in Raspbian for Robots. However, being on the same wireless network instead of my open “guest network” IS. (facepalm)

  2. noVNC does NOT work for me - well, sort-of doesn’t work. . .
    I can “connect” to a noVNC web page at :8001, but it “failed to connect to server”, and there appears to be nothing I can do about it. Since the VNC included with the 'bot is a spin-off of the payware Real VNC, maybe you need an account?

  3. I really don’t like the idea of two different things trying to run the same (kind of) service at the same time. Like two AV programs, or two web servers, etc. - it seems like the fast boat to disaster. How would I go about disabling the stock server if I set up tightvnc?

That’s what you see when you change the password from Robots1234 - If you look at the URL the password is right in there - There should be a Connect button in the middle of the page, click it and the noVNC will ask for your password - enter your pi user password.

1 Like

YOU probably should not. And the flask server would still be serving the web console.

I believe this stops (persistently) the novnc.service but I really haven’t a clue if this is the “proper” way to turn it off.

Use at your own risk

sudo systemctl stop novnc 

And to restart it:

sudo systemctl start novnc
1 Like

This is getting weird!

  1. I ditched the “realvnc” server that comes pre-installed and installed tightvncserver and tightvnc-java. (Realvnc got ditched automagically by apt.)

  2. Running “tightvncserver” for the first time, as root, (running it as a non-root user is about as useful as Teats on a Boar Hog!), it asked me for a password - which I supplied - and declined to create a view-only password. Note that the password I created was NOT “robots1234”.

  3. Since I already have it - I tried Windows Remote Desktop - which fails miserably.

  4. I wasn’t sure if the “noVNC” stuff would work because I ditched the RealVNC program, so I tried it again.
    What is interesting is that when I put in my bot’s IP address, it “automagically” filled in a whole bunch of URL, password, etc. Viz.:

Where did all THIS come from?!!

It DID connect, using the “default” password, not the one I specified. Interesting, but I’m still wondering what’s going on. If there’s one thing I hate in computers, it’s “magic”. I’d much rather know what the bejesus is going on and why.

Update: A thought. . .
During installation and initial config, a lot of automatic configuration stuff happened and it went by faster than I could read. (I’ll have to go find the …/vnc directory and look for the logs.) I have a sneaking suspicion that it “auto-configured” itself to “auto-connect” via the noVNC client.

A “P.S.”
I dropped the “ssh” and “ssh.txt” files in /boot and re "/boot"ed the system. Upon reboot, both of the “ssh” files were gone! (Shaking head)

I would have thought that, but it never did. Oh, and I never changed the password for the stock VNC server.

Is there a way, using these fora, to subscribe to “your” postings? Your stuff is usually very interesting and I enjoy wandering around to find another one of your “easter egg” postings hidden away somewhere.

Yes, that is the expected behavior - SSH is enabled after the file gets eaten.